Oct
28
2012

Fix : Windows 8 UI / Metro Apps shows splash screen but won’t launch

After reading this post you will be able to fix an issue where none of your Windows 8 UI apps formerly known as Metro UI apps wont launch. You try opening the app and it creates multiple entries in device manager, but the application itself will not launch. This issue happens when your Windows 8 system detects a time-out. Your application is required to open in a specific time & due to some problem your application times out and does not open, while you do see a splash screen. In some cases when you press ALT + TAB, you can still the splash screen of your app.

Fixing the issue:

  • Go to Your computer / system manufacturers support website
  • Select Windows 8 as your operating system
  • Download and Install the latest SATA / AHCI drivers ( storage controllers )
  • Restart your computer

Step 2

  • Press Windows key + X
  • Click on Command Prompt (admin)
  • type SFC /SCANNOW
  • let this run & wait until the process finishes
  • restart your machine

Step 3

Antivirus Update

  • This step mostly applies to AVAST & Norton users
  • Either Update or Uninstall / Reinstall your Antivirus application
  • To Uninstall, Go to start screen & type uninstall a program
  • Select your antivirus from the list & click on uninstall.
  • OR
  • Update your antivirus software
  • Open your Antivirus software application
  • Locate the update section
  • Press update icon
  • let the updates finish
  • Restart your computer

Method 6

Microsoft Apps Troubleshooter

Method 7

Check if UAC is Disabled

  • Go to the start screen
  • Type control panel
  • Locate View ( Top Right corner )
  • Set View to Large icons
  • Open User accounts
  • Click on Change User Account Control Settings
  • Set it to the Second Level from the Top

 

This should fix your problem. If not, use the comment section below to notify me & i will try to fix your issue further.

Related Posts

About the Author:

Shantanu is a Windows Enthusiast, a troubleshooter & a writer. He is a Microsoft MVP in Windows Expert - IT Pro from 2007. You can check out his other work @ www.shantanukaushik.com

73 Comments+ Add Comment

  • I have an Asus laptop. I could not find SATA/HCI driver. they did not mention windows 8 and I could not request a specific driver. It seems they have a massive download with many drivers. If you could help me navigate their website I would appreciate it. I will continue to look in the mean time.
    thanks

  • Could you please tell me the model no. of your Asus laptop ?
    You can also checkout windows update. Go to the optional updates section and see if it has some driver updates.

  • could you calrify what SFC/SCANNOW does will it affect programs settings etc thank you

    • Sure,

      SFC or System File Checker is a tool / utility integrated into the Windows operating system. It’s primary function is to check for corruption within the protected system files & replace them, if necessary, from the cached version of the same file that Windows keeps as a backup.
      /SCANNOW : directs the SFC command to run immediately, check for problems in system files & replace them if necessary.

      & it does not affect your program settings or any other settings. It’s core System File checker utility that works on system files.

  • I tried those ways but nothing happened
    but i notice that happened after installing bet defender .. I uninstalled it but also nothing happened

  • Possibly worth mentioning that you need to run sfc/scannow with administrator privileges.

    • Thanks :)
      Article edited.

      Regards

  • I have a brand new Asus UX32. I tried all. Except te first one “Go to Your computer / system manufacturers support website”. Updated all Windows. Than even tried refresh Windows installation. Although it is written taht I will not löse anything, I even lost Office trial installation.
    I don’t want to be Microsoft tester, how can I install Windows7. Thank you in advance.

    • You upgraded from windows 7 to 8 or did you fresh install windows 8 ?

  • Thank you for your answer. I freshly installed Windows 8 with the new computer. It was working. I only loaded Office, itunes, Sony PlayMemories and metro programs are not working anymore. By default it has McAfee virüs program. I have updated all Asus drives and softwares (SATA AHCI was already updated), all Windows 8. Accuweather was not working, after reinstallation it is working now. Reinstallation of programs seems to solve the problem. Do I have a chance to install Windows 7 or renstall all metro programs? Microsoft refuses to help due to my product ID classification, which I did not understand.

    • Have you tried uninstalling your antivirus software ( McAfee ) ?
      How did you buy windows 8 ? did it came with your computer or you bought it online ?

      Also, did you computer came with windows 7 preloaded ? if yes, you can go back to windows 7.

      I am willing to help you all I can. Please answer my questions above to enable me to further help you.

  • Also,

    Try running this : http://go.microsoft.com/fwlink/?LinkId=271185

    Microsoft troubleshooter

  • I have uninstalled McAfee before refreshing. It reinstalled with refreshing. It has just updated also it is currently active.
    Windows 8 came with Asus. It was not loaded, installed itself, when I first open the computer asking me about he requied info.
    I did not have chance to choose Windows 7. it was directly with Windows 8.
    I run Microsoft troubleshooter. It fixed some corrupted files (I did not understand how happened within e few days) and restarted.
    Today Nvidia olsa updated şt’s drivers.
    Still mail, contacts, calender, photo, skydrive, etc. not running :(

  • Maps was working, yesterday, now it is not working either after all updates.
    Thank you in advance.

  • I solved the problem. If you uninstall the non-working program and reinstall from app center, it works. Updated of the program don’t work.
    Due to Refresh garbages(!), I decided to reinstall Windows. Than first updated Windows and Asus drives. This time the problem did not ocur, luckly. Thank you for your support.

    • Nice to know that your problem is solved :)

  • Excellent. Thanks, friend.
    Have been helping my father with his two laptops, both running Win8 (which I installed).
    Older Asus has been relatively stable, but the newer (3 month old Samsung) has not had Win8 running stable for more than a few days.
    The latest was driving me crazy: It was the problem of Metro apps (90% of them) opening up and closing in a second or two.
    I did not think I could easily reinstall the native apps (mail, photos,etc) – but did so after reading your steps. And it worked beautifully.
    It’s interesting that the older laptop (2008) seems to work better than the Samsung.

    Have many observations about Win8, but the main one is that there are so many bugs in it that there are a million solutions out there – so even if the symptoms are the same, it looks like every post has a different solution that worked for that person.

    Personally, I like the concept, I think the W8 interface design is visually stunning. It really looks good – but am worried that there are just too many unresolved issues, design problems under the covers. I just hope MS does not choose to ignore them.
    I do know that the interface and visual aspects have made my 86 year old father surf the net, look at his photos, etc etc – much more than he ever did on Win7.

    cheers,
    rashad

    • Hello,

      I am glad that this article helped you.

  • I’ve tried all the steps and nothing seems to work. And, unfortunately, I did not set up system restore after installing Windows 8 so there is no restore point and to fix this it looks like a reload. What do you all think?

    • Please share your computer informaiton / specifications /model & make. I would be happy to help you. also, do share if you upgraded to windows 8 from windows 7 or is it a fresh install ?

      Regards

  • I’ve tried all the recommendations above minus the first (updating drivers) although, I can’t see why that would make a difference. It all worked before when I updated to window 8. Aside from quirks with win 8, metro was working fine. I have an HP laptop/ pavillion dv-7 i7 core
    any help appreciated…thanks

    • Hello,

      AHCI – SATA drivers ( proper drivers for windows 8) are responsible for correct disk operations in Windows. I was facing the same problem and my problem was fixed once i updated the AHCI drivers. The problem is caused due to latency of data / command / response transmission.

      Please let me know if updating the drivers help you.

  • EXCELLENT! I ran the Microsoft Apps Troubleshooter and I can now launch Metro apps!!!

    Thank you!!

  • Tried all of the above and still can’t use apps….they were working a few days and then stopped working. Please help.

  • im using acer v3 471g with preinstalled windows 8. my apps dont start and keep on loading. ive tried using some of the methods posted –
    method 2 – ive tried sfc scannow. it stops at 51%. with this message
    “windows resource protection corrupt filesbut was unable to fix some of them. details are included in CBS.log windir\logs\cbs\cbs.log. …..note that logging is currently not supported in offline servicing scenarios”

    method 3 – uninstalled avira AV, now using defender. – still not fixed. btw is win defender for windows 8 a good AV choice?

    method 6 – if i run the apps troubleshooter it gives two detected errors aetnd prompts me to restart. but after restart it is not yet fixed, and if i run app troubleshooter again same problems.
    a. Checking for missing or corrupt files (detected)
    b. microsoft account required (detected)
    for item b, i’ve made a windows and account and tried to sync it but windows cannot connect to the internet even if internet connection is well and good(windows update even works).

    method 7 – i cant find UAC when i search from start.

    i have even tried refreshing but after refreshing it says “no changes were made to your PC”

    i would appreciate the help shan. thanks

    • Hi,

      1.It looks like that your core installation is having problems. SFC /SCANNOW should always complete, if it says that there is a problem, then it should by all means fix it.
      2. Windows Defender in Windows 8 “equals” Microsoft security essentials in Windows 7. I am using just that and works fine for me :)
      3. If apps troubleshooter also says that there is a problem & ultimately ( after restart ) again finds the problem, this would be second instance of a core installation problem.
      4. You can find UAC in Control panel as well( Control Panel -> User accounts ) ( make sure your view setting is set to “large icons” ) – After opening user accounts click on Change User Account control settings )
      5. If your computer is unable to perform a Refresh, I am very much sure that your problem is with corruption in system files or a BAD install.

      Conclusion & Possible Resolution : If you can & you are comfortable with clean installation. I would suggest you to re-install Windows by performing a format.

    • Hi, if your pc is an acer, uninstall atheros wifi card drivers, then your pc should refresh with no problems. re-install the wifi driver afterwards.

  • thank you for the response. i am not comfortable with clean installation, but i guess i have no choice. since my OS is OEM and i dont have CD for reinstallation do i use the “remove eveything and reinstall windows” setting?

    do i have to backup all files in my hard disk? even if they are on partitions other than C:? will these files get deleted?

    thanks shantanu

    • So sorry for the late reply :( Yeah you can choose that setting, but haven’t you created a Recovery disc yet ? Acer must have provided you with information regarding the same ? if not, contact acer support to ask about clean installing windows with recovery DVD. Other partitions will not be affected, but it is always advisable that you backup your data. better safe then sorry right ? :)

  • I have an HP Envy h8 1400 which came with Win 8 preinstalled. (It also had Norton Security Suite, which I never activated.) I’ve had the machine for several weeks, and my apps worked fine until a couple of days ago, when they acted like what you describe here. (But not all of them; Wikipedia and Store worked) The rest would either immediately go back to the start screen (while showing as active in the sidebar) or just sit on the start screen with the “wait” dots whirring around. I did EVERYTHING you mention in this article and they still don’t work. The app trouble shooter said that I had some problems in the registry or something, said it reset things, but still nothing. I had already uninstalled Norton completely, and deleted all of its many files, so that can’t be the problem.
    I have to say, this is very irritating. Please help!
    Thanks.

    • Hi,

      I can understand how you must be feeling. Let’s try a few things so that we can pin point the root cause

      1. You are using HP Envy H8 1400 ( an u please confirm the exact model no. ) Check from the website mentioned below:
      http://h20000.www2.hp.com/bizsupport/TechSupport/ProductList.jsp?lang=en&cc=us&taskId=135&prodTypeId=12454&prodSeriesId=5295996

      2. Please do backup all your data, just in case something goes wrong. After that uninstall the display / graphics driver from your computer & restart ( I am assuming you know how to uninstall the display driver )

      3. Go to the HP Support site or NVidia support website ( you have NVidia graphics right ? ) and download – install the latest 314.22 display drivers

      4. Restart and check if your apps are working again.

      5. Have your tried “Refresh Your PC” feature ?

      Regards

      • Thanks, shantanu.
        I aleady have updated the driver to the latest one. I didn’t want to refresh my PC since I have so many desktop programs (Office, Photoshop, etc) installed and configured. What I ended up doing was uninstalling all the apps and reinstalling them. Now they are working, but what a PITA! I think the OS should be updated to autocorrect whatever causes this to happen. Too many people have it happen, based on what turns up when I googled my problem.

  • Hi.
    I have this issue with my ASUS U36SD.
    I Have run the win 8 for about 6 mnd.
    first now, i get this error.

    the SFC scann gave me an errror message :
    “Windows Resource Protection found corrupt files but was unable to fix some
    of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
    example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
    supported in offline servicing scenarios.”

    The CBS.log file could not be opened in notes.
    Any suggestions ?

    • Hi & sorry for a bit late reply,

      you should be able to use notepad to open the log file. You can also upload this log file and give me a link, I can check it for you. You can also download and install notepad++ , that should easily open this file.

  • While accessing the icons in Windws 8.1 Pro, it says unable to launch the application contact system administrator for repairing or reinstalling this . Using the admnistrator a/c i am able to access these apps but using domain id. if this is having admin rights , unable to access !!! Any body can help me

    • Create a new user account and check if you can solve this problem. Try Metro UI troubleshooter as well

  • Went through all of your steps, but was not able to correct the app start then closes problem. I finally tried using a different account on the same machine — all of the apps worked from there. I guess this leads me to believe that something is wrong with my account, not the system, possibly something corrupted in my AppData?

    • Yes, I am very sure that something in your user account settings or app data went kaput.

  • I’ve tried a lot of your tips but none of my Windows 8 apps will launch. I have a HP Pavilion 20-b014 All-in-One Desktop PC. Product Number: H3Z01AAR Processor: AMD E1-1200 APU with RAadeon(tm) HD Graphics 1.40 GHz and 4GB RAM. Can you please help!?

    • Hi, Are you having this problem from day one ? or has this just started ?

  • I have done all of this…no help. I cant open any metro apps. I cant even open the app store. I tried to delete the calender and e-mail app and re install but now don’t know how or where to find them. I can’t refresh or even re install windows due to “files missing”. I cant recover these files because that option is being blocked. My restore points don’t work either. I’m at a loss. Cant fix issue or even start from the beggining. Have had this hp envy m6……..model m6-1105dx with windows 8 since december 2012…please help.

    • also….I cant re-install the deleted apps from the store because I cant open the store app????

      • I tried using hp support system. That does not open. I cant un-install it either. it reaches an error both from starting and removing it. That doesn’t make sense. your help would be apreciated.

    • Hi, Read all your comments, I will suggest you this : Go to Control panel -> users -> and create a new user account & login from that account and check if the problem still persists. If yes, then reinstalling Windows seems the only way to fix your problem.

  • I was having this problem yesterday with my Windows 8 setup after installing new AMD drivers.

    For me, the issue was that I enabled Morphological Anti-aliasing in AMD Catalyst control center. Turning it off fixed everything. The same problem lies with nVidia drivers.

    It seems Windows 8 metro apps also run in full screen DirectX mode so the driver thinks it is a game when it is not and fails to apply anti-aliasing which prevents the app from rendering on screen.

    • Thanks Saurav, Nice addition to the topic.

  • Hi,

    I tried most of the above steps, but still have problem where apps show the splash screen, but don’t run.

    I have a new HP ENVY dv6-7398ca Notebook PC.

    When I go to download the SATA/AHCI drivers, the closest I see is: Intel Rapid Storage Technology Driver. I downloaded and installed that driver.

    When I run SFC /SCANNOW, it completes, but displays a message to the effect: problems were found, but was not able to fix all of them. When I restart, I see the message that Windows is configuring… do not turn machine off. So I know the SFC did something.

    I have Norton AV, so I uninstalled and reinstalled it. Ran the apps troubleshooter, and made sure User Account Access setting is correct.

    Any suggestions?

    • Have you tried resetting your PC ?

      • What exactly do you mean by “resetting”?

        • Windows 8 has a in-built functionality that lets you reset your PC ( Dump Everything and reinstall Windows), its an automated process. Just go to the start screen and type reset -> click on setting in the right hand pane and select the option that says ” Reset”. Note, that this will delete any programs and setting that you might have on your drive in which Windows is installed. Make sure you backup everything. Plus, you can select if you wish to wipe your drive or keep all data during the reset wizard.

          This will reinstall Windows on it’s own

          • Thanks for the info, Shantanu. When I have some time, I’ll give resetting a try.

            Greg

  • I had this problem on an MS Surface Pro and after trying the options above, found the only thing that worked was uninstalling and reinstalling all the apps – but even then a couple still didn’t work.

    Creating a new user account and installing all the apps again fixed the problem – a bit of a hassle setting it all up again, but better than resetting or reinstalling Windows.

  • lenovo t420s – all drivers from lenovo site – fresh legal system, windows 8 (disk formated on 8 sempember) – all metro aps dont work! im tring every fix (a cant ad user beacose it in metro ui)

    • ok Try this : Press Windows logo key + X on your desktop and Click on Command Prompt(admin)
      Now, type Control userpasswords2 -> Click on Add user. Let me know if this works

  • I have vaio e series laptop, having same issues with apps not launching except my problem is much worse, I tried resetting but from my main account I can’t even start the search so I took your advice and made second account and I was able to open search and access settings but when I tried to reset it just kept on shutting it down and going to start screen, if u have any other ideas it would be greatly appreciated.

  • I tried that multiple time it just keep closing settings or any apps from the start menu, is there any other way to reset or reinstall windows

    • Try this: On your lock screen -> keep pressing shift & click on Restart -> this will open a quick repair mode -> try resetting from there

  • Hi, I am using a Lenovo IdeaPad Y510P computer. I bought it brand new from the Lenovo website about a month ago. It came with Windows 8 already installed on it. It has worked perfectly until about a couple weeks ago. It started when absolutely none of my Metro/Windows 8 apps would open.

    None of the apps respond at all when I click on them. The store is the only one that actually responds, it opens for a couple seconds and then closes again. I understand a lot of people have had this problem, but none of the solutions I’ve tried have worked. I’ve tried the following list of solutions to no avail whatsoever:

    1. Checking UAC.
    2. Rebooting. A million times.
    3. Upgrading and then uninstalling my virus protection software (McAfee)
    4. I actually updated ALL of my drivers, graphics, storage, audio, everything just in case, didn’t work.
    5. Doing the SCANNOW.
    6. Running the Windows App troubleshooter (It says it detected some potential problems, has me reboot, but nothing changes)
    7. THIS is my biggest problem. I got desperate enough to try refreshing my PC, I didn’t want to, but I really wanted my apps back. It didn’t work. It rebooted, then it showed a loading screen which said “Refreshing your PC”; it jumps to about 11% and then stops. It then restarts and says that it failed to refresh my PC. No error code, no help page, no nothing. The recommended fix I found for this was refreshing my PC from the Windows 8 installation disk. I do not have a Windows installation disk or anything, since Windows 8 came with my PC.

    Help would be greatly appreciated. I have searched all over, both for restoring my apps to working order and being able to refresh my PC. No results. I could do a clean reinstall of Windows, but that will doubtless be messy and I’ll have to reinstall so much stuff… If you could find time to help me out I would greatly appreciate it.

  • Hi, I am having the same problem, my apps show the splash screen but it wont open. it closes immediately. I dont have an antivirus, instead im running windows defender. my apps wont open and i cant do a system restore because an antivirus is blocking one file for some reason.

    • Hey Vince, try making another user account. Login with that account and see if the apps work.

  • Having the same problem. I setup 2 accounts before upgraded to 8.1. They are working ok.
    After upgrading to 8.1, any account I setup is showing all apps with the x mark. Even the store.
    Spent 3 hours with HP for support, since it’s a new computer. They tried everything. Couldn’t fix it. Now they want to to reset and go back to 8.0. What a waste of time.
    If 8.1 is not ready yet, why did they release it? Something basic a Metro apps not installing is just appalling.
    And this is a new HP laptop. When I was younger, I had time to fiddle around with this kind of stuff. Now, I just want stuff to work. This may force me to go buy the MAC.

  • Hello, I have a Samsung laptop with native Windows 8. I’ve updated to 8.1. Everything was working fine until this happened. Now I can’t open any Metro apps, not even the store to uninstall them. I don’t have any updated to install, I’ve run SFC /SCANNOW the troubleshooter and also checked for the UAC and it seems OK. What can I do to solve this problem?

    • Try to create another user account by going to users in Control panel. Then logout of the current user profile and login with the new user profile to check if the apps are working.

      If nothing works, the only solution is to reset your pc. To do that. Go to the start screen -> click on your account at the top right corner and click on logout -> now, while on the welcome screen -> press and hold the shift key & click on the power button -> click on restart ( keep holding shift key ) -> when the repair window appears release the shift key & click on troubleshoot -> then look for the option to reset your PC ( remember -> before resetting your pc, backup all your data )

  • I found that making a new user account fixes this issue too

  • Thank you so much for posting this suggestion, this really save my day. I have been using Windows since Windows 3.1 and I would say I am really a fun of using the net everytime I encounter a promblem with my system. But the solution to this problem is really annoying. Most sites give the same solution not so much of alternative.

    This problem is really annoying (never had this problem in my windows 8 installation), I installed a fresh RTM version of Windows 8.1 and I think after some Windows Updates most Windows native apps had a problem lauching. I tried almost all of the suggested solution that I could find in google search result regarding this problem to no avail. So last night just before retiring and being tired on fixinng this problem. I decided to just restore my system to an earlier time, I have an AIOMEI multiple incremental system backup, but not so sure where among these backups did the problem starts. Besides, I think if I restore my system and later on do a Windows Updates the problem will soon come back. Just as I am about to start the restore process. I decided to give google one more try, and gladly I found this suggestion.

    I gave SFC /SCANNOW a try with hesitation, this is something really different to most suggestions I found. After some time and some more reading, the scan is finally finished. Restarted my computer and to my surprise all APPS ARE WORKING FINE.

    P.S. I did drop by to your blog site and found some interesting articles there. Keep up the good work and continue sharing your knowlege.

  • Here is my problem, sorry if its been answer but i didn’t see it. So all of my metro apps do not work i am not able to make a new account so i could use that one bc like what was said in the article i get a splash art but the app does not and will not load or respond. I’ve tried all of the steps but idk what i can do. I am thinking about reverting back to windows 7 but this computer has 8 on it from the time i bought it. Its a Asus Republic of gamers Laptop. Processor Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz, Ram 8.00GB, and System 64-bitOS

  • I recently Purchased a HP Envy 17-j101TX Laptop with windows 8.1.
    The apps on the start screen that are ‘live’ scroll their information, but NONE will run, including the static apps. When I click them their splash screen opens and then the PC reverts back to the Start Window. It is only the ‘Metro Apps’, Desktop apps work fine. I have tried all the above and in the end I refreshed the installation. this fixed the problem until I once again installed a few of my desktop apps, when I discovered that the apps would no longer work. I could do another refresh, but I’m figuring that it will only happen again when I reinstall my desktop apps. After two days of messing about I’m less than impressed with windows 8. Hope you can suggest another alternative than refreshing..And I hope the Boffins at Microsoft know how flakey Win8 is and are working on a fix.

    • Your laptop came with Windows 8.1 or 8 ?

      • Sorry, It came with Windows 8.1. I should have been more specific in my posts.

        • There are a few things that might help you specifically.

          1. Try Making a New user account & do not add a Microsoft Account, instead, just use a local account. ( This is just for testing purposes )
          2. What Kind of Antivirus Solution are you using ?
          3. Press Windows Logo key + X & click on Command Prompt ( admin ) -> now, type services.msc and check if Windows Firewall service is running or not.
          4. Check, If your computer has some Display drivers Installed ( Maybe Nvidia or ATI or Intel ) ( I am talking about official drivers from them & not the ones that came Windows Installed )
          5. Can u retrace your steps on when exactly the APPS stopped working ? What I mean is, what were the desktop applications you installed that you mentioned in your reply

          • Hi Shantanu
            1. User account added. It only added 4 apps, but none apart from IE worked.
            Did the same thing, Opens the splash screen and then returns to the main start screen.
            (interesting to note that upon returning to my regular login and trying the apps after
            setting the new user account, the apps open with a blank black screen instead of their
            splash screen, but if you slide from the ‘windows logo’ in the task bar (to reveal
            the running apps) their splash screen is being displayed.)

            2. McAfee Live safe, came preinstalled.

            3. I updated the display drivers to the latest Nvidia (downloaded from Nvidia) in
            an attempt to fix the problem

            4. I installed Incredimail, checked apps, worked. Installed FIrefox, checked apps,
            worked. Installed Corel X4 (including the official service packs and hotfixes)
            checked Apps, not working . Uninstalled Corel, apps not working.

            “Refreshed” PC which removed all that I installed.
            Apps Working again.
            Installed Corel X4, checked Apps, Worked, Installed Firefox, Checked apps, Worked,
            Installed Incredimail, Checked apps, Not working.

          • Oopps Sorry, 3 should be Checked services, Windows FIrewall service Running

Leave a comment